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HOW-TO Digitally Retouch Photos in GIMP
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T
his month, our subject 
is digital retouching of 
photographs. 
Nowadays, 

unblemished or even perfect 
faces are the rule on magazine 
covers and billboards. In this 
article I'll show you some 
general cosmetic retouching 
techniques.

Professional photographers 
and artworkers digitally 
retouch in a few different ways. 
Some use Gimp or similar 
tools, Others prefer filters. 
Here, we will use both together. 
We'll retouch in a practical way. 
First, we'll see how to remove 
acne from photos.

Open the photo (my source 
image is shown left) in Gimp 
and check it for defects.

I've detected the following 
defects:

1. Flash reflections on the face.
2. Acne on the face.
3. Lines and wrinkles
4. Suboptimal colors. 

Now, one by one, we will 
apply our solutions. We'll begin 
by removing the acne and 
spots. The healing tool will be 
used for this. Choose 
the healing tool (right) 
from the toolbox. Its 
shortcut key is H.

Healing Tool
Now we need to choose a 

brush. Circle Fuzzy (shown 
below, selected) is a suitable 
option. You can change the size 
of the brush by increasing / 
decreasing the scale value.

The healing tool is for 
removing acne and spots. First, 
with + and  -  zoom into the 
photo. Then mark the best 
color option - while pressing 
CTRL, then release the CTRL 
and click on the acne/spot.

You should see that the acne 
has disappeared. You should 

perform the same process for 
all acne/spots.

All acne has been removed. 
Now it's time to remove the 
light from the flash - for this 
process we can use the clone 
tool or healing tool.

Clone Tool: Selectively 
copy from an image or 
pattern, using a brush.

In both tools, we maintain a 
low opacity value and we must 
do this by using different 
regions and for several 
attempts - not all at once. 
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While the Ctrl key is pressed, 
click on the location which has 
the ground color close to a 
shiny place. Click a different 
place again and do the same 
process. Let this process 
continue until the light from 
the flash is gone.

Now we'll select some parts 
of the face. Choose the Free 
Select tool from the toolbox.

Free Select Tool: 
Select a hand-drawn 
region with free and 

polygonal segments

We will need to do more than 

one selection, so we'll 
choose the add to 
selection icon shown 
right.

We choose the face as our 
first selection, then, after 
clicking the add to selection 
icon we hold down SHIFT and 
draw a second selection 
around the hand.

We choose the borders of 
the area that we would like to 
work on. If you make any 
mistake, you can use 
backspace to undo the 
previous action.

Now we should deselect 
some parts from our selection.
•  Eyes
•  Eyebrows
•  Nostril
•  Accessories

Choose the third 
option from the 
toolbox:

Deselect the parts that we 
have mentioned.

Don't forget to apply feather 
after each selection. Select > 
Feather and a value of 5 pixels.

Then apply a filter. Click, 
Filters > Blur > Gaussian Blur.

Choose suitable values, and 
click OK.

Press Shift + Ctrl + A or 
choose  from the Select 
menu.

 The last thing is 
correcting the colours. Click 
Colours > Colour Balance. The 
How-To for more information on 
this will be our next tutorial.

This picture has a CC licence from 
Brenda Annerl
http://www.flickr.com/photos/brendaan
nerl/2729960358/sizes/m/

http://www.flickr.com/photos/brendaannerl/2729960358/sizes/m/
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FCM#34 - Retouch Photo's - Part 1

GraphicsDev Internet M/media System

HDDCD/DVD USB Drive Laptop Wireless

I
n this article we will learn 
how to edit dark and light 
 tones in our photos. First 
of all, I would like explain 

colors and their ranges. There 
are different color profiles, we 
have three main colors within 
light and they are Red, Green 
and Blue (RGB). Another color 
profile is CMYK this is a mix of 
the main ink colors and is 
usually used in photos, printers 
and press.

Histogram
The Histogram graph shows 

us the range of all the colors or 
a single color. How should be 
the color graph look? Let's 
explain it with some examples.

Above we have a photo with 
light and mid tones but no dark 
tone.

Now we 
go to 
Dockable 
Dialogs > 
Histogram 
from the 
menu. If you 
check the 
histogram 
(left), you 
can easily 
see which 

tones are not in your photo.

Let's check our second 
example (above right). 

In this histogram, we have 

mid and dark 
tones but no 
light tones 
(right).

Now, our 
third 
 example:

Here we 
have all mid 
tones and no 
light or dark.
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If there is a problem with 

the colors in a photo, we can 
easily correct things by using 
either the Levels dialog or 
Brightness/Contrast settings. 

Now we choose Colors > 
Levels.  This pop-up represents 
the mix of RGB colors as it 
stands.

From “Channel” you can 
reach the histogram of RGB. 
We can edit them one by one. 
The “Auto” button can edit the 
tones automatically, but this 
isn't always correct. 

There are three  “Pick” 
buttons next to the "Auto” 
button. They are for dark , mid 
and light tones. You can click 
them one by one and choose 
the suitable tone point. 

The best way is by doing it 

manually. You can do this by 
dragging the triangles, which I 
have marked with circles (left), 
to the start and end points of 
the histogram. Then you can 
find the best tone by changing 
the position of the middle 
triangle. You can then use 
Brightness/Contrast to make 
colors sharp.

Let's go to Colors > 
Brightness/Contrast and 
choose:
+25 Brightness
+15 Contrast 

Now our photo should look 
like this.

You can edit the tone of the 
other photos as we did there. 

The second tool we can use 
is the Adjust Color Curves. This 
tool has similar properties as 
the “Levels” tool but it has a 
few little extras. With it we can 
increase the density of colours.

Let's open our first photo 
and choose Colors > Adjust 
Color Curves. In the pop-up 
window, the starting and 
ending points can be changed 
and tones can be adjusted.

That's all for this issue. The 
next article will tell you more 
about colour adjustment.

All photos are licensed by Public 
Domain.

Translated from Turkish to English by 
Kaan Bahadır TERMELİ
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FCM#34-35 - Retouch Photos 1 - 2

GraphicsDev Internet M/media System

HDDCD/DVD USB Drive Laptop Wireless

H
ere is the final article 
regarding color 
correction. Here we 
will introduce color 

adjustment in GIMP by 
examining a few example 
images. Let's start with the first 
example:

There is too much yellow in 
the picture, and a lack of blue. 
To correct this we will open the 
Color Balance tool (top right) 
from the Colors menu.

To return the picture to true 
color levels (right) we need to 
increase the level of blue in 
this window. 

If you notice a lack, or 
excess, of any colors - 
including cyan, red, magenta, 
green, yellow or blue - Color 
Balance is a good option to 
correct this problem.

Of course, we can use this 
tool for just a selected area by 
using the select tool.

Let us analyse another 
picture.

It can be said the density of 
colors is too high in this 
picture. The best way to solve 
this problem is by using the 
Hue-Saturation Tool which is in 
the Colors Menu.
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We can decrease the 
saturation value of the pictures 
to make them return to natural 
colors. Lightness is used to 
adjust the level of darkness-
lightness. Hue can mix the 

colors. It creates colors to 
replace other colors. Generally, 
we don't use Hue to adjust 
colors. But it is the best tool if 
you want to change any color.   

Let us examine this picture 
that has a high level of yellow 
color density.

Another way to adjust colors 
is by using the Levels tool from 
the Colors Menu. We will adjust 
each color level separately. 
Start with one color, then try to 
find the true color level by 
moving the rectangles 
(especially the middle one). 

Once we adjust all colors, 
this is our result. 

I will finish my article after 
giving some short information 
about GIMP.

Gimp can let us automate 
some work. Some tools which 
are in the Colors menu:

 

These are really effective 
and easy to use. For the 

features of this tool, you can 
visit 
http://docs.gimp.org/2.6/en/ 
where you can also find a lot of 
documents on other aspects of 
GIMP.

If your scanner has an 
option to scan film negatives, 
you can scan them, then use 
the Colors > Invert tool to turn 
them into positives. 

All images are public domain license 

Author: H seyin SARIGÜL

Translated from Turkish into 
English : Mehmet SARIGÜL

http://docs.gimp.org/2.6/en/
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I
n the first of this new GIMP

series, I’m going to try and

show you some intermediate

techniques. In other words,

things that people may think are

possible only with Photoshop. If

you’d like to read more about the

absolute basics of GIMP, then I

refer you back to FCM#12-19.

While I used an older version of

GIMP in those issues, the layout of

GIMP has changed little in the

passing years.

For ideas, I’m using Photoshop

tutorials that are freely available

on the web, and, while not copying

them step for step, applying the

underlying principles of them to

GIMP.

I should also state, for the

record, that I’m using GIMP 2.6. As I

write this, a 2.7 version is available,

but, it is not entirely compatible

with the *buntu family, and trying

to install it can give conflicts.

What we’ll be making is shown

left.

Sources:

Sky -

http://www.2textured.com/index.p

hp/Environment/Skies/skies_0347

YouTube Video showing Pt1 being

made:

http://www.youtube.com/watch?v=

NYFTdbzjubg

The Sky Gradient

First thing we need to do is

create a new image (File > New),

and make it A4 in size, portrait in

orientation, and with an X and Y

resolution of 80. The default X and

Y resolution is 300. That’s for

professional printing, and, it

requires high resolution images as

source material, and can slow down

even the hardiest of machines - so

we’ll go with 80 which is more than

adequate for this tutorial.

Select the ‘Blend tool’

icon (shown left), and,

where it says ‘Shape:’,

choose ‘Radial’ from the drop down

menu. No need to change anything

else for now. For a foreground

color, choose a very pale greeny-

yellow (RGB = 220, 229, 189). For

the background, choose a slightly

faded greeny-yellow (RGB = 133,

151, 81).

Next, left click (and hold) in the

middle of the blank image and

move up to the top middle of the

image. Release the mouse button

and you’ll have a radial fill covering

the entire canvas.

http://www.2textured.com/index.php/Environment/Skies/skies_0347
http://www.youtube.com/watch?v=NYFTdbzjubg
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No, Not The Layers!

Click File>Open, and choose

your sky image. To quickly get the

sky into our main image, we go to

the ‘Layers’ tab and (as shown

above) drag it onto our main image

With the sky now in our main

image, you can close the opened

sky image.

The sky image is quite

high resolution, larger

than we require, so we

need to resize it. Click the ‘Resize’

tool (shown left), and click the sky.

In the resize window that pops up,

you need to make sure that the

little chain link icon is linked. If the

icon looks like a broken chain, then

your sky image will resize

disproportionately and squish.

Make the width of the sky about

300 wide, and click OK. This gives

us some room to play with.

Click the ‘Move’ icon

(shown left). Now, left

click and drag the sky

icon to where you think it looks

best.

TIP: The gradient is one layer and

the sky is another. If we add several

more layers, it’ll get quite

confusing. To make things easier

you can double click on a layer

name and rename it.

Now for some layer magic. With

the sky layer still selected, click the

drop down menu above the layers

and choose ‘Value’.

Color Curve

You’ll now have a greeny sky,

but it doesn’t look very dramatic

does it? With the sky layer still

selected, click Colors > Curves from

the menu. We’re going to create

what’s known as an S-curve. The S-

curve is a great way of quickly color

correcting your photos too. Click

two boxes across and two down in

the grid, and drag your mouse up

and to the left slightly, and two

boxes in and up from the bottom

HOWTO - GIMP: THE BEANSTALK Pt1
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left of the grid, and click and drag

down to the right.

Which will give you an S-curve

(shown above) which you should

play around with until you get a

nice dramatic sky with good darks,

but not too bright lights.

Let’s finish off this sky and

that’ll do us for this first part of the

tutorial.

Layer Mask

Right click on the sky layer, and

from the menu, choose ‘Add Layer

Mask’ (shown below).

From the window that pops up,

choose ‘White (full opacity)’ and

click ‘Add’. You’ll see a box appear

next to your sky thumbnail in the

list of layers.

That box is a thumbnail of the

layer mask. The idea is that if you

select that layer thumbnail, and

draw in black, you’ll erase parts of

the sky image. Draw over the

erased area with white and the sky

will reappear. This means you can

show/hide parts of the sky - using

the mask - without destroying the

original sky image. We’ll use the

mask to fade the sky into the

background.

Make sure the mask

thumbnail is selected, it

should have a white

outline, and click the “Rectangle

Select’ icon (shown below left).

Left click and draw a box around

the bottom third of the sky.

Now click the ‘Blend Tool’ icon

(that we used at the start of this

tutorial), but make sure the

‘Shape:’ is Linear this time. You’ll

need a foreground colour of black,

and a background colour of white.

With that all set, click and drag just

up from the bottom middle of the

selected area, to just below the top

middle of the selected area, and

release the mouse button.
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HOWTO - GIMP: THE BEANSTALK Pt1

Your sky will now magically fade

into the background. And since it’s

a layer mask, the original sky is

untouched. You can right click on

the layer mask and delete it and

the sky will return to its original

state.

Next month we’ll add a piece of

landscape below the sky, and

maybe, just maybe, start growing

that beanstalk. Class dismissed!

The Ubuntu Podcast covers all

the latest news and issues facing

Ubuntu Linux users and Free

Software fans in general. The

show appeals to the newest user

and the oldest coder. Our

discussions cover the

development of Ubuntu but

aren’t overly technical. We are

lucky enough to have some

great guests on the show, telling

us first hand about the latest

exciting developments they are

working on, in a way that we can

all understand! We also talk

about the Ubuntu community

and what it gets up to.

The show is presented by

members of the UK’s Ubuntu

Linux community. Because it is

covered by the Ubuntu Code of

Conduct it is suitable for all.

The show is broadcast live every

fortnight on a Tuesday evening

(British time) and is available for

download the following day.

podcast.ubuntu-uk.org

http://www.youtube.com/watch?v=NYFTdbzjubg
http://ronnietucker.co.uk
http://podcast.ubuntu-uk.org/


full circle magazine #61 21 contents ^

HHOOWW--TTOO
Written by Ronnie Tucker GGIIMMPP -- TThhee BBeeaannssttaallkk PPtt22

O
K, so, we’ve got our sky

recoloured and fading

into the background;

next, we want to have

a little village below the sky.

Sources:

Village:

http://www.sxc.hu/browse.phtml?f

=view&id=1215281

Tree:

http://alfoart.com/flash/beanstalk

_tutorial/625100_53361668.jpg?ht

tp://www.2textured.com/main.php

?g2_itemId=281

YouTube:

http://www.youtube.com/watch?v

=KTmehu8x2j4

The Village

Bring the village photo into

your scene. How? This is where I

test if you’ve read part one or not.

Same idea: open the village image

and drag it into our main scene.

You’ll probably have to resize it to

about 750 pixels wide, though.

Should you see something like

this, don’t panic

If you look at the list of layers,

you’ll see that the village layer is

sandwiched between the sky and

background images. We need the

village to be at the top of the list.

Simply drag it up above the sky

layer.

Click the move icon, and drag

the village layer down to the

bottom of the image.

We’re going to chop away some

excess trees that are behind the

village to give us a nice landscape.

Selections

The selection tools are some of

the most important tools in GIMP

as they allow you to be as detailed

as you need to be when selecting

an outline. For this, our first big

tutorial, we’ll go with a quick and

dirty selection.

Click the ‘Free Select Tool’

(shown left) and draw around the

treeline keeping only

full trees. Draw out the

side of the image, and

loop back to where you started.

Press the Enter key on your

keyboard to complete the

selection.

You can, of course, go clockwise

if you prefer.

Press the Delete key on your

keyboard, and anything inside that

selection will be removed.

TIP: If you press the Delete key

and the selected area shows black,

then you’ll have to go to the menu,

click Edit > Undo. Right click on the

layers thumbnail, and choose ‘Add

Alpha Channel’. Now you can press

Delete to remove your selection.

This extra ‘Add Alpha Channel’ step

isn’t always necessary.

http://www.sxc.hu/browse.phtml?f=view&id=1215281
http://alfoart.com/flash/beanstalk_tutorial/625100_53361668.jpg?http://www.2textured.com/main.php?g2_itemId=281
http://www.youtube.com/watch?v=KTmehu8x2j4
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You can, if you like, go around

the treeline and tweak it with the

eraser, but for now we’ll cover it up

with a layer mask. You do

remember how to create a layer

mask, don’t you? Yep, right clicking

on the village layer, and choosing

to add a white layer mask.

Use the rectangle select tool to

select the top half of the village

(below left) and, like last time, use

a black and white linear gradient to

fade the top part of the village.

Remember last time

how I spoke about the

layer mask as being

non-destructive? Well,

here’s your chance to try it out. We

created a white layer which was

completely transparent, so choose

a foreground colour of white and

click the ‘Paintbrush’ icon (shown

left).

TIP: If you need to enlarge/shrink

the paintbrush you can use the

square bracket keys (that’s [ and ]).

The idea here (shown below

right) is to (on the layer mask!)

paint white over some of the

foreground trees to remove them

from the fog effect in the

background.

OK, let’s get our whopping

great tree inserted and we’ll finish

up part two.

I’ll show you another quick way

of inserting an image. Click the link

above for the tree source. In your

browser, right click the image and

copy the image to the clipboard.

Go to your main image in GIMP,

and, in the menu, click Edit > Paste

As > New Layer. Voila!

HOWTO - GIMP: THE BEANSTALK Pt2
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HOWTO - GIMP: THE BEANSTALK Pt2
You’ll have to resize the layer to

about 600 pixels wide, and move it

down to have the tree roots

halfway down the grassy part of

the village. Clicking resize, and

then on the tree, I’m unlinking the

width and height numbers as I just

want to stretch the tree vertically

to about 650 high.

Like we did with the village, it’s

time to trim out the excess

background, we just want to keep

the tree. Time to click the free

select tool and get to work.

This time we want to keep

what’s inside the selection, so, in

the menu, click Select > Invert and

press Delete. One tree. But I think

I’d like it growing up to the right,

so click Layer > Transform > Flip

Horizontally. I’d also like it to have

a tint of green like the rest of the

image, so click Colors > Colorize,

and move the ‘Hue’ slider until you

get a greenish tint to the tree.

Finally, apply a layer mask to

the tree layer, and select the top

third of the tree and use the blend

tool to fade the tree into the

clouds.

One last thing, your homework

for this lesson: use the

Dodge/Burn tool on the village

layer to paint a shadow from the

tree across the grass.

In the final part of the

Beanstalk image we’ll add some

pizazz to the image.

http://www.youtube.com/watch?v=KTmehu8x2j4
http://ronnietucker.co.uk
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W
e’re almost done

with the beanstalk

image, but I’d like to

add some random

bits and bobs to give it some

pizzazz.

Sources:

Moon:

http://www.sxc.hu/photo/1126941

Stars:

http://www.sxc.hu/photo/1005288

YouTube Video:

http://www.youtube.com/watch?v

=HZcoOx94ox8

Moonshine

Copy/paste the moon image

into the beanstalk scene. I’m

keeping the moon layer at about

150 wide and have flipped it

horizontally.

This time, in the dropdown

menu above the list of layers,

choose ‘Screen’; the black in the

layer will vanish, and the moon will

blend in nicely.

Although, a glow around it

wouldn’t go amiss. We’ll cheat with

the glow and use a filter. Click

Filters > Artistic > Softglow. Move

the sliders until you get something

pretty. I used a high brightness and

glow radius.

The good thing about doing this

in a non-destructive manner is that

you can change anything at any

time without having to completely

redo chunks of the image. I’m

going to use an S-curve now on the

tree as I think it needs to have

brighter highlights on it and that

hollow should be nice and dark.

One last thing is that I’m going

to add some stars to the sky, so it’s

time to bring in the image of the

stars: place the layer below the

moon layer, and make it about 300

pixels wide. This time though,

make the layer mode ‘Lighten only’

from the dropdown menu. The last

thing to do is give the stars a layer

mask that will fade them out

midway down the image.

Next month we’ll have a tutorial

from Thomas Standiford on

making your photo look retro.

http://www.youtube.com/watch?v=HZcoOx94ox8
http://ronnietucker.co.uk
http://www.sxc.hu/photo/1126941
http://www.sxc.hu/photo/1005288
http://www.youtube.com/watch?v=HZcoOx94ox8
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HHOOWW--TTOO
Written by Thomas Standiford GGIIMMPP -- RReettrroo PPhhoottoo

I
n this GIMP how-to, we're

going to do some basic curves

adjustments to make this

photo have a cool stylized

retro-type look.

We'll start with the image

above right, and end with the

image shown bottom right.

Get the Retro Colors

Most of the effect for this

photo is simply from adjusting the

curves of each channel (the red,

green, blue, and alpha channels)

like so:

Note: To change which channel to

adjust, select the channel from the

channel drop-down. You can switch

back and forth between channels.

All of these curves adjustments

should be done in ONE

COMMAND, not a series of four

commands.

After making the adjustment,

your photo should look pretty cool,

but we need to tone the contrast

down a bit.

Next, do another curves

adjustment like so:
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HOWTO - GIMP RETRO PHOTO

Not bad, now if only those

bubbles didn't disappear in the

process.

Enhance the Bubbles

The bubbles seem to have

disappeared in this photo. We're

going to use a combination of

selections, and soft brushes to put

some pop back into them.

Create a new layer, name it

"bubbles".

Now we will select the bubbles.

Using the path tool, trace around

the outer edge of each bubble.

Once all of the bubbles have

been outlined, right-click on the

path in the path menu (located in

the same window as the layers),

and click "path to selection."

Set your foreground and

background to a lime green and

hot pink.

Using a fairly large and soft

brush, carefully brush in a few

spaces of pink and green in each

bubble, like so:

Now that we have added the

color to the proper areas of the

bubbles, let's change some layer

styles and adjust the opacity to

make the bubbles look realistic.

Set the layer mode to Overlay.

Duplicate the layer. Name the

duplicated layer "bubblebrighten".

Set the duplicated layer mode

to addition.

Adjust the opacity of both the

"bubble" and "bubblebrighten"

layer until you end up with

something you're happy with. My

opacity settings are set to 23 and

40 respectively, and they look like

this:

Now that our bubbles are a

little more visible, let's dramatize

the photo a bit.

Final Touches

Create a new layer, name it

"dramatize", set the layer mode to

Overlay, and fill the layer with

black.

Add a layer mask to the

dramatize layer.

Using the blend tool, set the

gradient mode to radial, and use a

gradient that goes from black to

white. Create a gradient that goes

from the center of the photo

outward. Adjust the opacity of the

layer to something you're happy

with. Here is what I ended up with:

Next month we'll begin a video

editing series using Kdenlive.


